summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2021-06-11 14:45:12 +0200
committerJoerg Bornemann <joerg.bornemann@qt.io>2021-06-14 10:33:31 +0200
commit0aa36661440005d7c4618164e5d51d19dac529ca (patch)
treeaddba2ec3362ca9578925e374bfdf74333364ec3 /CMakeLists.txt
parent8329ec476b3dc9bb7ffd17ee724b6b21c17e90ec (diff)
downloadqttools-0aa36661440005d7c4618164e5d51d19dac529ca.tar.gz
Remove unneeded CMake variable assignments
Remove assignments to the transitionary variables QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS and QT_USE_FIXED_QT_ADD_RESOURCE_BASE. Both are not needed anymore. Task-number: QTBUG-94444 Change-Id: If287b713e7393f4b82de0a511a0c818510845e8b Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index aac132d27..9f6a92f09 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,12 +13,6 @@ project(QtTools # special case
# special case begin
set(QT_REPO_NOT_WARNINGS_CLEAN TRUE)
-# Make sure we only use latest private CMake API, aka no compatibility wrappers.
-set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
-
-# Make sure we use the fixed BASE argument of qt_add_resource.
-set(QT_USE_FIXED_QT_ADD_RESOURCE_BASE TRUE)
-
# add platform specific compontents
set(optional_components "")
if(WIN32)