summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLi Xinwei <1326710505@qq.com>2020-11-20 19:28:28 +0800
committerLi Xinwei <1326710505@qq.com>2020-11-22 01:01:12 +0800
commit1338e2405df3d0d03d55c68e0b804e5e7f872649 (patch)
tree0ad5649a4d440e3c27fdf143f3e8d3e1a64017b8 /CMakeLists.txt
parent5c08a8c207fdcc27aed53478d3c082d44e4be395 (diff)
downloadqttools-1338e2405df3d0d03d55c68e0b804e5e7f872649.tar.gz
CMake: Fix missing qdbus.exe and qdbusviewer.exe on Windows
Qt DBus module is also available on Windows. Excluding it from optional components of Win32 will prevent building qdbus.exe and qdbusviewer.exe. Pick-to: 6.0.0 6.0 Change-Id: Id2cb4965beb8f136c62c42a80bc9b922d0ffca3b Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index be0ba4ab1..8b763d244 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,13 +20,11 @@ set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
set(optional_components "")
if(WIN32)
list(APPEND optional_components AxContainer)
- else()
- list(APPEND optional_components DBus)
endif()
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Network)
find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS
- Xml Widgets Quick QuickWidgets QmlDevTools
+ DBus Xml Widgets Quick QuickWidgets QmlDevTools
Sql PrintSupport OpenGL OpenGLWidgets ${optional_components})
# special case end