summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2023-02-08 14:04:17 +0100
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2023-02-08 22:49:41 +0100
commit1e0539ea51b75d9404ccc9506fcc0cdfa6951307 (patch)
treeb9033bc13a4f4611cf430a92236e9b93c460904e /CMakeLists.txt
parent1f859ca1ac6d337aedde2fe8eed74266416ae0d1 (diff)
downloadqttools-1e0539ea51b75d9404ccc9506fcc0cdfa6951307.tar.gz
Remove remains of qmake conversion from CMakeLists.txt files
Pick-to: 6.5 Change-Id: Ic00df7d45246270d724b3b1d1ef9d13d76dcc136 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 2 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c3f4e4e5e..8ef7bc58c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,14 +1,13 @@
# Copyright (C) 2022 The Qt Company Ltd.
# SPDX-License-Identifier: BSD-3-Clause
-# Generated from qttools.pro.
cmake_minimum_required(VERSION 3.16)
include(.cmake.conf)
-project(QtTools # special case
+project(QtTools
VERSION "${QT_REPO_MODULE_VERSION}"
- DESCRIPTION "Qt Tools" # special case
+ DESCRIPTION "Qt Tools"
HOMEPAGE_URL "https://qt.io/"
LANGUAGES CXX C
)
@@ -26,9 +25,5 @@ find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS
qt_build_repo()
-# special case begin
-
# Add tool dependencies that were deferred by qt_internal_add_docs.
qt_internal_add_deferred_dependencies()
-
-# special case end