summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-08-19 13:36:57 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-08-28 11:16:24 +0000
commit4d40bffe8109a68f06a1b42ccc57dfaa8d5ce011 (patch)
treeec6d04330450dbf77f86851e6822d7eb18cf9c57 /CMakeLists.txt
parentf3d047af903801d9e7705816df5299c4e04a76f4 (diff)
downloadqttools-4d40bffe8109a68f06a1b42ccc57dfaa8d5ce011.tar.gz
Initial port to CMake
Includes the main bits and also projects under src/linguist. Task-number: QTBUG-76002 Change-Id: I5fa9144c834f245ab85fc831c8e58afd8d02800e Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 000000000..2e3dc6af2
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,12 @@
+cmake_minimum_required(VERSION 3.15.0)
+
+project(QtTools
+ VERSION 6.0.0
+ DESCRIPTION "Qt Tools"
+ HOMEPAGE_URL "https://qt.io/"
+ LANGUAGES CXX C
+)
+
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core
+ OPTIONAL_COMPONENTS Xml Widgets Quick QuickWidgets)
+qt_build_repo()