summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-10-20 16:13:37 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-10-21 11:47:41 +0200
commit539efef79cc4d83bb7afcba7e62a1586fd3f36c5 (patch)
tree5921e5674b803e0f8de1367ec8cbd52457da43bf /CMakeLists.txt
parent0867b74d0381c9b5b0cbff6cc5d24a4d6b9e8ad9 (diff)
downloadqttools-539efef79cc4d83bb7afcba7e62a1586fd3f36c5.tar.gz
CMake: Make optional packages not being found a bit quieter
Task-number: QTBUG-86053 Change-Id: I9afbea16b8b71f78a77ff77efd57397b438eba60 Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 72b838c96..85c57dcf1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -25,8 +25,9 @@ if(WIN32)
endif()
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Network)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Xml Widgets Quick QuickWidgets QmlDevTools
- Sql PrintSupport OpenGL OpenGLWidgets ${optional_components})
+find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS
+ Xml Widgets Quick QuickWidgets QmlDevTools
+ Sql PrintSupport OpenGL OpenGLWidgets ${optional_components})
# special case end
qt_build_repo()