summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristophe Giboudeaux <christophe@krop.fr>2020-05-05 17:02:13 +0200
committerChristophe Giboudeaux <christophe@krop.fr>2020-05-07 11:42:32 +0200
commit6830628b0970905479fd3e73059e574c619e9039 (patch)
treef4d5838acb07e115c4fc50631369a245a4e592ad /CMakeLists.txt
parentc89669828c4527832fcd7f375ede91366694e076 (diff)
downloadqttools-6830628b0970905479fd3e73059e574c619e9039.tar.gz
cmake: Add Qt6Dbus to the optional dependencies list
The build system checks whether the 'Qt::DBus' target is available before building src/qdbus. Change-Id: I29bd8305cfc32d1a07847aecb94054ed8f8988c7 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 757abece1..107371eed 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,7 +12,7 @@ project(QtTools # special case
# special case begin
set(QT_REPO_NOT_WARNINGS_CLEAN TRUE)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Network)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Xml Widgets Quick QuickWidgets QmlDevTools Sql PrintSupport OpenGL OpenGLWidgets)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS DBus Xml Widgets Quick QuickWidgets QmlDevTools Sql PrintSupport OpenGL OpenGLWidgets)
# special case end
qt_build_repo()