summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Hausmann <simon.hausmann@qt.io>2019-11-22 09:37:22 +0100
committerSimon Hausmann <simon.hausmann@qt.io>2019-11-22 09:32:19 +0000
commit7ee63f412379f55287aa471f284f3a49f9796b60 (patch)
treec115c6fb59aa34b86638ad40704145d31607d604 /CMakeLists.txt
parentb9eb81fe1f5cfc1d74e7ec30a2eb7407063f89b3 (diff)
downloadqttools-7ee63f412379f55287aa471f284f3a49f9796b60.tar.gz
Fix build
Designer needs Qt::Network and since it's not conditional in src, let's make it a required package. Change-Id: I23ebe8a298999b87b5e4ca0d2a03d97568182d55 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 603606ba7..764696b1f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,7 +11,7 @@ project(QtTools # special case
# special case begin
set(QT_REPO_NOT_WARNINGS_CLEAN TRUE)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Network)
find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Xml Widgets Quick QuickWidgets)
# special case end