summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-11-12 17:26:56 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-11-12 16:44:03 +0000
commitf46489d856c347d38fac502f75370c87c83b8cee (patch)
tree429a1db0a93d927267a86a47a9ff276b020fe205 /CMakeLists.txt
parentbd94ebbc85cc42564a618eed2e5fb7bcac8753aa (diff)
downloadqttools-f46489d856c347d38fac502f75370c87c83b8cee.tar.gz
Mark qttools as not being warnings clean
So that compilation doesn't fail when the WARNINGS_ARE_ERRORS option is enabled. This mimics what .qmake.conf warning_clean does. Change-Id: I511697c226465e67b14762fd2c52c90e0270a8fc Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 65f584507..603606ba7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,8 +9,11 @@ project(QtTools # special case
LANGUAGES CXX C
)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core) # special case
-find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Xml Widgets Quick QuickWidgets) # special case
+# special case begin
+set(QT_REPO_NOT_WARNINGS_CLEAN TRUE)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Xml Widgets Quick QuickWidgets)
+# special case end
qt_build_repo()