summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index be0ba4ab1..8b763d244 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,13 +20,11 @@ set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
set(optional_components "")
if(WIN32)
list(APPEND optional_components AxContainer)
- else()
- list(APPEND optional_components DBus)
endif()
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Network)
find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS
- Xml Widgets Quick QuickWidgets QmlDevTools
+ DBus Xml Widgets Quick QuickWidgets QmlDevTools
Sql PrintSupport OpenGL OpenGLWidgets ${optional_components})
# special case end