summaryrefslogtreecommitdiff
path: root/examples/assistant/simpletextviewer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/assistant/simpletextviewer/CMakeLists.txt')
-rw-r--r--examples/assistant/simpletextviewer/CMakeLists.txt16
1 files changed, 5 insertions, 11 deletions
diff --git a/examples/assistant/simpletextviewer/CMakeLists.txt b/examples/assistant/simpletextviewer/CMakeLists.txt
index fb4f100be..b6b9fcc8e 100644
--- a/examples/assistant/simpletextviewer/CMakeLists.txt
+++ b/examples/assistant/simpletextviewer/CMakeLists.txt
@@ -1,23 +1,15 @@
-# Generated from simpletextviewer.pro.
-
cmake_minimum_required(VERSION 3.16)
project(simpletextviewer LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/assistant/simpletextviewer")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Widgets)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Widgets)
qt_add_executable(simpletextviewer
assistant.cpp assistant.h
@@ -26,12 +18,14 @@ qt_add_executable(simpletextviewer
mainwindow.cpp mainwindow.h
textedit.cpp textedit.h
)
+
set_target_properties(simpletextviewer PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
+
target_compile_definitions(simpletextviewer PUBLIC
- SRCDIR="${CMAKE_CURRENT_SOURCE_DIR}/" # special case
+ SRCDIR="${CMAKE_CURRENT_SOURCE_DIR}/"
)
target_link_libraries(simpletextviewer PUBLIC