summaryrefslogtreecommitdiff
path: root/examples/linguist/arrowpad/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/linguist/arrowpad/CMakeLists.txt')
-rw-r--r--examples/linguist/arrowpad/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/examples/linguist/arrowpad/CMakeLists.txt b/examples/linguist/arrowpad/CMakeLists.txt
index 94b003262..882136b95 100644
--- a/examples/linguist/arrowpad/CMakeLists.txt
+++ b/examples/linguist/arrowpad/CMakeLists.txt
@@ -18,12 +18,21 @@ set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/linguist/arrowpad")
find_package(Qt6 COMPONENTS Core)
find_package(Qt6 COMPONENTS Gui)
find_package(Qt6 COMPONENTS Widgets)
+#! [0]
+find_package(Qt6 REQUIRED COMPONENTS LinguistTools)
+#! [0]
qt_add_executable(arrowpad
arrowpad.cpp arrowpad.h
main.cpp
mainwindow.cpp mainwindow.h
)
+#! [1]
+qt6_add_translations(arrowpad
+ TS_FILES arrowpad_fr.ts arrowpad_nl.ts
+ QM_FILES_OUTPUT_VARIABLE qm_files)
+install(FILES ${qm_files} DESTINATION ${INSTALL_EXAMPLEDIR})
+#! [1]
set_target_properties(arrowpad PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE