summaryrefslogtreecommitdiff
path: root/examples/uitools/textfinder/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/uitools/textfinder/CMakeLists.txt')
-rw-r--r--examples/uitools/textfinder/CMakeLists.txt15
1 files changed, 4 insertions, 11 deletions
diff --git a/examples/uitools/textfinder/CMakeLists.txt b/examples/uitools/textfinder/CMakeLists.txt
index 96911c675..17c6a9522 100644
--- a/examples/uitools/textfinder/CMakeLists.txt
+++ b/examples/uitools/textfinder/CMakeLists.txt
@@ -1,33 +1,27 @@
-# Generated from textfinder.pro.
-
cmake_minimum_required(VERSION 3.16)
project(textfinder LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/uitools/textfinder")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Widgets)
-find_package(Qt6 COMPONENTS UiTools)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui UiTools Widgets)
qt_add_executable(textfinder
main.cpp
textfinder.cpp textfinder.h
)
+
set_target_properties(textfinder PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
+
target_link_libraries(textfinder PUBLIC
Qt::Core
Qt::Gui
@@ -35,7 +29,6 @@ target_link_libraries(textfinder PUBLIC
Qt::Widgets
)
-
# Resources:
set(textfinder_resource_files
"forms/input.txt"