summaryrefslogtreecommitdiff
path: root/src/compositor/CMakeLists.txt
diff options
context:
space:
mode:
authorElvis Lee <kwangwoong.lee>2021-08-26 17:32:09 +0900
committerEskil Abrahamsen Blomfeldt <eskil.abrahamsen-blomfeldt@qt.io>2021-12-10 19:02:09 +0100
commit8e89118c0a33f7c865714bf86be29a475d004b51 (patch)
treee85eb99c16910a98bcaacb98160a1004a797b6de /src/compositor/CMakeLists.txt
parent0ef4f6f239c8ad590eeb1a0a6a7c8ba254305fb1 (diff)
downloadqtwayland-8e89118c0a33f7c865714bf86be29a475d004b51.tar.gz
Support presentation-time protocol
With the protocol, client knows accurate presentation timing which can support vsync-based rendering for smooth video playback with video/audio synchronization. Also, the protocol provides metrics from client to on-screen for optimizing frame latency. Tested with weston-presentation-shm client which also requires xdg shell. Change-Id: I3b286420e7221aa1c9b81bf7ae9ae70d3cbe6eb6 Reviewed-by: Eskil Abrahamsen Blomfeldt <eskil.abrahamsen-blomfeldt@qt.io>
Diffstat (limited to 'src/compositor/CMakeLists.txt')
-rw-r--r--src/compositor/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/compositor/CMakeLists.txt b/src/compositor/CMakeLists.txt
index 95118afb..560597bb 100644
--- a/src/compositor/CMakeLists.txt
+++ b/src/compositor/CMakeLists.txt
@@ -93,6 +93,7 @@ qt6_generate_wayland_protocol_server_sources(WaylandCompositor
FILES
${CMAKE_CURRENT_SOURCE_DIR}/../3rdparty/protocol/idle-inhibit-unstable-v1.xml
${CMAKE_CURRENT_SOURCE_DIR}/../3rdparty/protocol/ivi-application.xml
+ ${CMAKE_CURRENT_SOURCE_DIR}/../3rdparty/protocol/presentation-time.xml
${CMAKE_CURRENT_SOURCE_DIR}/../3rdparty/protocol/scaler.xml
${CMAKE_CURRENT_SOURCE_DIR}/../3rdparty/protocol/text-input-unstable-v2.xml
${CMAKE_CURRENT_SOURCE_DIR}/../3rdparty/protocol/text-input-unstable-v4-wip.xml
@@ -159,6 +160,7 @@ qt_internal_extend_target(WaylandCompositor CONDITION QT_FEATURE_wayland_composi
extensions/qwaylandquickxdgoutputv1.cpp extensions/qwaylandquickxdgoutputv1.h
extensions/qwaylandwlshellintegration.cpp extensions/qwaylandwlshellintegration_p.h
extensions/qwaylandxdgshellintegration.cpp extensions/qwaylandxdgshellintegration_p.h
+ extensions/qwaylandpresentationtime.cpp extensions/qwaylandpresentationtime_p.h extensions/qwaylandpresentationtime_p_p.h
LIBRARIES
Qt::QmlPrivate
Qt::QuickPrivate