summaryrefslogtreecommitdiff
path: root/src/compositor/CMakeLists.txt
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2022-01-03 18:56:09 +0100
committerUlf Hermann <ulf.hermann@qt.io>2022-02-05 07:25:19 +0100
commitdb98b0d52b1ebd388bf9fc0ed2b1fefd01515927 (patch)
tree9ee34f16582b614dd261de0d883de6f18a79fedb /src/compositor/CMakeLists.txt
parent88bc19d0f7eb04d43cef6c5be0e0e31ad4ecf8fc (diff)
downloadqtwayland-db98b0d52b1ebd388bf9fc0ed2b1fefd01515927.tar.gz
Adapt to moving of type registrations into the Qt namespace
... and make the type registration function private. As we already have a private global header, let's use it. The public global header should not have the "We mean it" warning either. Change-Id: If4424652528c7886ce56e676d633aa3968f3772b Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/compositor/CMakeLists.txt')
-rw-r--r--src/compositor/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/compositor/CMakeLists.txt b/src/compositor/CMakeLists.txt
index 560597bb..e2113629 100644
--- a/src/compositor/CMakeLists.txt
+++ b/src/compositor/CMakeLists.txt
@@ -42,7 +42,7 @@ qt_internal_add_module(WaylandCompositor
extensions/qwaylandxdgshell.cpp extensions/qwaylandxdgshell.h extensions/qwaylandxdgshell_p.h
extensions/qwlqtkey.cpp extensions/qwlqtkey_p.h
extensions/qwlqttouch.cpp extensions/qwlqttouch_p.h
- global/qtwaylandcompositorglobal.h
+ global/qtwaylandcompositorglobal.h global/qtwaylandcompositorglobal_p.h
global/qtwaylandqmlinclude.h
global/qwaylandcompositorextension.cpp global/qwaylandcompositorextension.h global/qwaylandcompositorextension_p.h
global/qwaylandquickextension.h