summaryrefslogtreecommitdiff
path: root/tests/auto/client/surface/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/client/surface/CMakeLists.txt')
-rw-r--r--tests/auto/client/surface/CMakeLists.txt23
1 files changed, 1 insertions, 22 deletions
diff --git a/tests/auto/client/surface/CMakeLists.txt b/tests/auto/client/surface/CMakeLists.txt
index 0674f7de..93cfb2fb 100644
--- a/tests/auto/client/surface/CMakeLists.txt
+++ b/tests/auto/client/surface/CMakeLists.txt
@@ -6,28 +6,7 @@
qt_internal_add_test(tst_surface
SOURCES
- ../shared/corecompositor.cpp ../shared/corecompositor.h
- ../shared/coreprotocol.cpp ../shared/coreprotocol.h
- ../shared/datadevice.cpp ../shared/datadevice.h
- ../shared/mockcompositor.cpp ../shared/mockcompositor.h
- ../shared/textinput.cpp ../shared/textinput.h
- ../shared/xdgoutputv1.cpp ../shared/xdgoutputv1.h
- ../shared/xdgshell.cpp ../shared/xdgshell.h
tst_surface.cpp
- INCLUDE_DIRECTORIES
- ../shared
PUBLIC_LIBRARIES
- Qt::Gui
- Qt::OpenGL
- Qt::WaylandClientPrivate
- Wayland::Server
- Threads::Threads # special case
-)
-
-qt6_generate_wayland_protocol_server_sources(tst_surface
- FILES
- ${CMAKE_CURRENT_SOURCE_DIR}/../shared/../../../../src/3rdparty/protocol/text-input-unstable-v2.xml
- ${CMAKE_CURRENT_SOURCE_DIR}/../shared/../../../../src/3rdparty/protocol/wayland.xml
- ${CMAKE_CURRENT_SOURCE_DIR}/../shared/../../../../src/3rdparty/protocol/xdg-output-unstable-v1.xml
- ${CMAKE_CURRENT_SOURCE_DIR}/../shared/../../../../src/3rdparty/protocol/xdg-shell.xml
+ SharedClientTest
)