summaryrefslogtreecommitdiff
path: root/src/imports/webchannel
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/webchannel')
-rw-r--r--src/imports/webchannel/CMakeLists.txt32
-rw-r--r--src/imports/webchannel/dependencies.json2
-rw-r--r--src/imports/webchannel/plugin.cpp35
-rw-r--r--src/imports/webchannel/plugins.qmltypes67
-rw-r--r--src/imports/webchannel/qmldir4
5 files changed, 0 insertions, 140 deletions
diff --git a/src/imports/webchannel/CMakeLists.txt b/src/imports/webchannel/CMakeLists.txt
deleted file mode 100644
index 52405c8..0000000
--- a/src/imports/webchannel/CMakeLists.txt
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: BSD-3-Clause
-
-# Generated from webchannel.pro.
-
-#####################################################################
-## webchannel Plugin:
-#####################################################################
-
-qt_internal_add_qml_module(webchannel
- URI "QtWebChannel"
- VERSION "${PROJECT_VERSION}"
- PAST_MAJOR_VERSIONS 1
- CLASS_NAME QWebChannelPlugin
- PLUGIN_TARGET webchannel
- NO_PLUGIN_OPTIONAL
- NO_GENERATE_PLUGIN_SOURCE
- NO_GENERATE_QMLTYPES
- INSTALL_SOURCE_QMLTYPES "plugins.qmltypes"
- SOURCES
- plugin.cpp
- INCLUDE_DIRECTORIES
- ../../webchannel
- LIBRARIES
- Qt::Core
- Qt::Quick
- Qt::WebChannelPrivate
-)
-
-#### Keys ignored in scope 1:.:.:webchannel.pro:<TRUE>:
-# IMPORT_VERSION = "1.$$QT_MINOR_VERSION"
-# TARGETPATH = "QtWebChannel"
diff --git a/src/imports/webchannel/dependencies.json b/src/imports/webchannel/dependencies.json
deleted file mode 100644
index 0d4f101..0000000
--- a/src/imports/webchannel/dependencies.json
+++ /dev/null
@@ -1,2 +0,0 @@
-[
-]
diff --git a/src/imports/webchannel/plugin.cpp b/src/imports/webchannel/plugin.cpp
deleted file mode 100644
index 2914bb4..0000000
--- a/src/imports/webchannel/plugin.cpp
+++ /dev/null
@@ -1,35 +0,0 @@
-// Copyright (C) 2016 Klarälvdalens Datakonsult AB, a KDAB Group company, info@kdab.com, author Milian Wolff <milian.wolff@kdab.com>
-// SPDX-License-Identifier: LicenseRef-Qt-Commercial OR LGPL-3.0-only OR GPL-2.0-only OR GPL-3.0-only
-
-#include <qqml.h>
-#include <QtQml/QQmlExtensionPlugin>
-
-#include <qqmlwebchannel.h>
-#include <qqmlwebchannelattached_p.h>
-
-QT_BEGIN_NAMESPACE
-
-class QWebChannelPlugin : public QQmlExtensionPlugin
-{
- Q_OBJECT
- Q_PLUGIN_METADATA(IID QQmlExtensionInterface_iid)
-
-public:
- QWebChannelPlugin(QObject *parent = 0) : QQmlExtensionPlugin(parent) { }
- void registerTypes(const char *uri) override;
-};
-
-void QWebChannelPlugin::registerTypes(const char *uri)
-{
- int major = 1;
- int minor = 0;
- qmlRegisterType<QQmlWebChannel>(uri, major, minor, "WebChannel");
-
- // The minor version used to be the current Qt 5 minor. For compatibility it is the last
- // Qt 5 release.
- qmlRegisterModule(uri, major, 15);
-}
-
-QT_END_NAMESPACE
-
-#include "plugin.moc"
diff --git a/src/imports/webchannel/plugins.qmltypes b/src/imports/webchannel/plugins.qmltypes
deleted file mode 100644
index 68378d6..0000000
--- a/src/imports/webchannel/plugins.qmltypes
+++ /dev/null
@@ -1,67 +0,0 @@
-import QtQuick.tooling 1.2
-
-// This file describes the plugin-supplied types contained in the library.
-// It is used for QML tooling purposes only.
-//
-// This file was auto-generated by:
-// 'qmlplugindump -nonrelocatable -dependencies dependencies.json QtWebChannel 1.15'
-
-Module {
- dependencies: []
- Component {
- name: "QQmlWebChannel"
- prototype: "QWebChannel"
- exports: ["QtWebChannel/WebChannel 1.0"]
- exportMetaObjectRevisions: [0]
- attachedType: "QQmlWebChannelAttached"
- Property { name: "transports"; type: "QObject"; isList: true; isReadonly: true }
- Property { name: "registeredObjects"; type: "QObject"; isList: true; isReadonly: true }
- Method {
- name: "registerObjects"
- Parameter { name: "objects"; type: "QVariantMap" }
- }
- Method {
- name: "connectTo"
- Parameter { name: "transport"; type: "QObject"; isPointer: true }
- }
- Method {
- name: "disconnectFrom"
- Parameter { name: "transport"; type: "QObject"; isPointer: true }
- }
- }
- Component {
- name: "QQmlWebChannelAttached"
- prototype: "QObject"
- Property { name: "id"; type: "string" }
- Signal {
- name: "idChanged"
- Parameter { name: "id"; type: "string" }
- }
- }
- Component {
- name: "QWebChannel"
- prototype: "QObject"
- Property { name: "blockUpdates"; type: "bool" }
- Signal {
- name: "blockUpdatesChanged"
- Parameter { name: "block"; type: "bool" }
- }
- Method {
- name: "connectTo"
- Parameter { name: "transport"; type: "QWebChannelAbstractTransport"; isPointer: true }
- }
- Method {
- name: "disconnectFrom"
- Parameter { name: "transport"; type: "QWebChannelAbstractTransport"; isPointer: true }
- }
- Method {
- name: "registerObject"
- Parameter { name: "id"; type: "string" }
- Parameter { name: "object"; type: "QObject"; isPointer: true }
- }
- Method {
- name: "deregisterObject"
- Parameter { name: "object"; type: "QObject"; isPointer: true }
- }
- }
-}
diff --git a/src/imports/webchannel/qmldir b/src/imports/webchannel/qmldir
deleted file mode 100644
index c521f2f..0000000
--- a/src/imports/webchannel/qmldir
+++ /dev/null
@@ -1,4 +0,0 @@
-module QtWebChannel
-classname QWebChannelPlugin
-plugin declarative_webchannel
-typeinfo plugins.qmltypes