summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllan Sandfeld Jensen <allan.jensen@qt.io>2021-06-23 11:30:14 +0200
committerAllan Sandfeld Jensen <allan.jensen@qt.io>2021-06-30 09:07:05 +0200
commit1efcf20bcc1d41edb56d4ef491dc9c26b7a98f15 (patch)
treeca88369f8d33bc810e130077f7eda4f113193303 /CMakeLists.txt
parent7237c81bf20571fac2f898e7e29e7be386e3270a (diff)
downloadqtwebengine-1efcf20bcc1d41edb56d4ef491dc9c26b7a98f15.tar.gz
Pass compiler wrapper to GN
Pick-to: 6.2 Change-Id: I1ce6e9d0e03bb780f85636865e15552ac28876fa Reviewed-by: Michal Klocek <michal.klocek@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b5fdebc0a..e35fcf7b9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -120,6 +120,12 @@ list(APPEND libsCmakeArgs
"-DWEBENGINE_REPO_BUILD=TRUE"
"${featureList}"
)
+if (CMAKE_C_COMPILER_LAUNCHER)
+ list(APPEND libsCmakeArgs "-DCMAKE_C_COMPILER_LAUNCHER=${CMAKE_C_COMPILER_LAUNCHER}")
+endif()
+if (CMAKE_CXX_COMPILER_LAUNCHER)
+ list(APPEND libsCmakeArgs "-DCMAKE_CXX_COMPILER_LAUNCHER=${CMAKE_CXX_COMPILER_LAUNCHER}")
+endif()
if(LINUX)
set(cmd "${CMAKE_COMMAND} --build ${CMAKE_CURRENT_BINARY_DIR}/src")