summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2023-04-12 15:04:15 +0200
committerAlexey Edelev <alexey.edelev@qt.io>2023-05-03 12:35:32 +0200
commit34eff61f9c617062a1935826eb6afac675a85c9e (patch)
tree05a1b2856b9f6682e91514bee4ab71123abff04a /CMakeLists.txt
parentf64fe9781bd657a6f15c25fdea0b60b013bb0069 (diff)
downloadqtwebengine-34eff61f9c617062a1935826eb6afac675a85c9e.tar.gz
Add the use of the qt_internal_project_setup function
The function sets the required CMake variables and policies. Pick-to: 6.5 Task-number: QTBUG-112685 Change-Id: I5eb3f91a180f2a844a2575ed19abc28a913ce5b9 Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d3db42b40..faa9b1a51 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,6 +20,7 @@ project(QtWebEngine
HOMEPAGE_URL "https://qt.io/"
LANGUAGES CXX C
)
+qt_internal_project_setup()
find_package(Qt6 ${PROJECT_VERSION} CONFIG QUIET OPTIONAL_COMPONENTS
Gui Widgets Network OpenGL Quick Qml PrintSupport