summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2021-06-11 14:45:12 +0200
committerJoerg Bornemann <joerg.bornemann@qt.io>2021-06-14 16:27:07 +0200
commit981543eda6e5c99b43588eda5bc8ef18b5e00d76 (patch)
treed813a5f10abe74c57e3b091bd64c704be43cc757 /CMakeLists.txt
parentf7cde55256c0a0d7d1d87569bfc47aa35b8b7c64 (diff)
downloadqtwebengine-981543eda6e5c99b43588eda5bc8ef18b5e00d76.tar.gz
Remove unneeded CMake variable assignments
Remove assignments to the transitionary variables QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS and QT_USE_FIXED_QT_ADD_RESOURCE_BASE. Both are not needed anymore. Task-number: QTBUG-94444 Change-Id: I806c14db84f55a7edb53d0a30bc3ac2c9efbf432 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 63d227fc4..08d900d20 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,12 +11,6 @@ project(QtWebEngineRepoSuperBuild
LANGUAGES CXX C
)
-# Make sure we only use latest private CMake API, aka no compatibility wrappers.
-set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
-
-# Make sure we use the fixed BASE argument of qt_add_resource.
-set(QT_USE_FIXED_QT_ADD_RESOURCE_BASE TRUE)
-
option(FORCE_TEST_RUN "Forces test run after compilation" FALSE)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)