summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllan Sandfeld Jensen <allan.jensen@qt.io>2022-04-11 15:34:23 +0200
committerAllan Sandfeld Jensen <allan.jensen@qt.io>2022-04-13 16:45:38 +0200
commite618a38fc3aefbeecdd04d2217bfd23a9e55346e (patch)
tree4340b2a8dec78cb9b15cdc7d617e7e3b68f0ac26 /CMakeLists.txt
parent69cd28b820ba8f8c578591b98f3ad88b00efcef3 (diff)
downloadqtwebengine-e618a38fc3aefbeecdd04d2217bfd23a9e55346e.tar.gz
Build QtWebEngine with any Qt version >= 6.2
Pretend to be the same version to avoid having to hack qtbase Pick-to: 6.3 Change-Id: I537fcda3c6a6693892f0fef7d5f669b3670fa2d8 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d38a51e2f..c04b9bf46 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,14 +8,16 @@ include(ExternalProject)
include(cmake/Functions.cmake)
include(src/core/api/Qt6WebEngineCoreMacros.cmake)
+project(QtWebEngineDummy)
+find_package(Qt6 6.2 CONFIG REQUIRED COMPONENTS BuildInternals Core)
+
project(QtWebEngine
- VERSION "${QT_REPO_MODULE_VERSION}"
+ VERSION ${Qt6Core_VERSION}
DESCRIPTION "QtWebEngine and QtPdf modules"
HOMEPAGE_URL "https://qt.io/"
LANGUAGES CXX C
)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
find_package(Qt6 ${PROJECT_VERSION} CONFIG QUIET OPTIONAL_COMPONENTS
Gui Widgets Network OpenGL Quick Qml PrintSupport
WebChannel Positioning QuickControls2 Test QuickWidgets QuickTest WebSockets Designer