summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Klocek <michal.klocek@qt.io>2022-05-13 16:37:37 +0200
committerMichal Klocek <michal.klocek@qt.io>2022-06-09 08:31:41 +0200
commit80878be4ed0003d996edc01827b5638459a818c8 (patch)
tree9068b9bbfdefff7690d41808d109122835837f66 /src/CMakeLists.txt
parent64aea37067507c50178ee03eee9ad16a55bb7efe (diff)
downloadqtwebengine-80878be4ed0003d996edc01827b5638459a818c8.tar.gz
Fix 'flaky' gn install step
If gn is found in install path, still install it for qt host otherwise in case of reconfigure we never install. Pick-to: 6.3 6.2 Change-Id: I154e2ead386d52006e2647297b6148170b8a85cb Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 921871bee..e7600542e 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -144,6 +144,9 @@ if(NOT Gn_FOUND)
if(QT_FEATURE_qtpdf_build)
add_dependencies(run_pdf_GnReady gn)
endif()
+endif()
+
+if(NOT Gn_FOUND OR Gn_EXECUTABLE MATCHES "^${installDir}")
set(INSTALL_GN 1 CACHE INTERNAL "")
endif()