summaryrefslogtreecommitdiff
path: root/tests/auto/pdf/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/pdf/CMakeLists.txt')
-rw-r--r--tests/auto/pdf/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/auto/pdf/CMakeLists.txt b/tests/auto/pdf/CMakeLists.txt
index 8bda0c3c3..2f3f73961 100644
--- a/tests/auto/pdf/CMakeLists.txt
+++ b/tests/auto/pdf/CMakeLists.txt
@@ -2,7 +2,9 @@
# SPDX-License-Identifier: BSD-3-Clause
add_subdirectory(qpdfbookmarkmodel)
-#add_subdirectory(qpdfpagenavigator)
+if (TARGET Qt::PdfWidgets)
+ add_subdirectory(qpdfpagenavigator)
+endif()
add_subdirectory(qpdfpagerenderer)
if(TARGET Qt::PrintSupport)
add_subdirectory(qpdfdocument)