summaryrefslogtreecommitdiff
path: root/Source/WebCore/CMakeLists.txt
diff options
context:
space:
mode:
authorQt Forward Merge Bot <qt_forward_merge_bot@qt-project.org>2019-09-10 13:08:05 +0200
committerQt Forward Merge Bot <qt_forward_merge_bot@qt-project.org>2019-09-10 13:08:05 +0200
commit81cbb264cb9446c4408124d50aeff50164ad0ab4 (patch)
tree6acc39b8ea0165562d480f1c54608c6c4ae9f865 /Source/WebCore/CMakeLists.txt
parentbeaeeb99881184fd368c121fcbb1a31c78b794a3 (diff)
parent5087e0ced43d813eb6f765913a6fc3958d2a7a9d (diff)
downloadqtwebkit-81cbb264cb9446c4408124d50aeff50164ad0ab4.tar.gz
Merge remote-tracking branch 'origin/5.212' into dev
Change-Id: I4e185b15690118515df80a79b786cbb8b30dd144
Diffstat (limited to 'Source/WebCore/CMakeLists.txt')
-rw-r--r--Source/WebCore/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/Source/WebCore/CMakeLists.txt b/Source/WebCore/CMakeLists.txt
index e9fc4e54e..56b32563a 100644
--- a/Source/WebCore/CMakeLists.txt
+++ b/Source/WebCore/CMakeLists.txt
@@ -3354,8 +3354,13 @@ if (ENABLE_USER_MESSAGE_HANDLERS)
endif ()
if (USE_WOFF2)
- list(APPEND WebCore_INCLUDE_DIRECTORIES "${THIRDPARTY_DIR}/woff2/include")
- list(APPEND WebCore_LIBRARIES woff2)
+ if (WOFF2DEC_FOUND)
+ list(APPEND WebCore_INCLUDE_DIRECTORIES "${WOFF2DEC_INCLUDE_DIRS}")
+ list(APPEND WebCore_LIBRARIES "${WOFF2DEC_LIBRARIES}")
+ else ()
+ list(APPEND WebCore_INCLUDE_DIRECTORIES "${THIRDPARTY_DIR}/woff2/include")
+ list(APPEND WebCore_LIBRARIES woff2)
+ endif ()
endif ()
set(WebCoreTestSupport_INCLUDE_DIRECTORIES