summaryrefslogtreecommitdiff
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorKai Köhne <kai.koehne@qt.io>2022-02-14 19:50:46 +0100
committerKai Köhne <kai.koehne@qt.io>2022-02-19 08:56:50 +0100
commitfef6885a446165a02973c84469c87bebae389b96 (patch)
tree762d7762a7d9adfc14b92ff1e4aa44ba1500457d /examples/CMakeLists.txt
parent34eb3a620bc28a025a4afac043fb5258d15b9caf (diff)
downloadqtwebsockets-fef6885a446165a02973c84469c87bebae389b96.tar.gz
Improve examples CMakeLists.txt
- Remove "# generated from xyz.pro" comment from pro2cmake - Remove automatic use of CMAKE_AUTORCC - Only opt into CMAKE_AUTOUIC if .ui files are involved - Remove explicit setting of CMAKE_INCLUDE_CURRENT_DIR - Combine multiple find_package(Qt6 ... calls) - use REQUIRED COMPONENTS - sort components alphabetically - Fix wrong indentations - Use (only) one empty line after multi-line commands Pick-to: 6.3 Change-Id: I03507e56c961cfd6ae138473437dfafe478d3233 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Jörg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index afa018c..f1e09c7 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -1,5 +1,3 @@
-# Generated from examples.pro.
-
qt_examples_build_begin(EXTERNAL_BUILD)
add_subdirectory(websockets)