summaryrefslogtreecommitdiff
path: root/examples/websockets/qmlwebsocketserver/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/websockets/qmlwebsocketserver/CMakeLists.txt')
-rw-r--r--examples/websockets/qmlwebsocketserver/CMakeLists.txt46
1 files changed, 46 insertions, 0 deletions
diff --git a/examples/websockets/qmlwebsocketserver/CMakeLists.txt b/examples/websockets/qmlwebsocketserver/CMakeLists.txt
new file mode 100644
index 0000000..f7a196b
--- /dev/null
+++ b/examples/websockets/qmlwebsocketserver/CMakeLists.txt
@@ -0,0 +1,46 @@
+# Generated from qmlwebsocketserver.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(qmlwebsocketserver LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Quick)
+find_package(Qt6 COMPONENTS WebSockets)
+
+add_qt_gui_executable(qmlwebsocketserver
+ main.cpp
+)
+target_link_libraries(qmlwebsocketserver PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Quick
+ Qt::WebSockets
+)
+
+# Resources:
+set(data_resource_files
+ "qml/qmlwebsocketserver/main.qml"
+)
+
+QT6_ADD_RESOURCES(qmlwebsocketserver "data"
+ PREFIX
+ "/"
+ FILES
+ ${data_resource_files}
+)
+
+
+install(TARGETS qmlwebsocketserver
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)