summaryrefslogtreecommitdiff
path: root/examples/websockets/simplechat/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/websockets/simplechat/CMakeLists.txt')
-rw-r--r--examples/websockets/simplechat/CMakeLists.txt12
1 files changed, 4 insertions, 8 deletions
diff --git a/examples/websockets/simplechat/CMakeLists.txt b/examples/websockets/simplechat/CMakeLists.txt
index e69e3b7..0b6237b 100644
--- a/examples/websockets/simplechat/CMakeLists.txt
+++ b/examples/websockets/simplechat/CMakeLists.txt
@@ -1,30 +1,26 @@
-# Generated from simplechat.pro.
-
cmake_minimum_required(VERSION 3.16)
project(simplechatserver LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/websockets/simplechat")
-find_package(Qt6 COMPONENTS WebSockets)
+find_package(Qt6 REQUIRED COMPONENTS WebSockets)
qt_add_executable(simplechatserver
chatserver.cpp chatserver.h
main.cpp
)
+
set_target_properties(simplechatserver PROPERTIES
WIN32_EXECUTABLE FALSE
MACOSX_BUNDLE FALSE
)
+
target_link_libraries(simplechatserver PUBLIC
Qt::WebSockets
)