summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTor Arne Vestbø <tor.arne.vestbo@qt.io>2021-05-10 13:42:52 +0200
committerTor Arne Vestbø <tor.arne.vestbo@qt.io>2021-05-11 07:44:14 +0000
commit6037ece5e4c0d290ae4ebf75c0d9bce0de55ed85 (patch)
tree600a0cb2c37d279da0e654b092124d8c997dab54 /CMakeLists.txt
parent0e67fb41cfc4b4bfbaa7dc75f8ddebdf5a08e836 (diff)
downloadqtx11extras-6037ece5e4c0d290ae4ebf75c0d9bce0de55ed85.tar.gz
Remove module and add note about current status in Qt 6
QX11Info was merged into qtbase in edceff30b4093e2bef6e80c7552edf595134f351. Task-number: QTBUG-83251 Change-Id: I63372418a0d5a0adbb68f880e229bdd1e21d267e Reviewed-by: Liang Qi <liang.qi@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt29
1 files changed, 0 insertions, 29 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
deleted file mode 100644
index ccb1f5e..0000000
--- a/CMakeLists.txt
+++ /dev/null
@@ -1,29 +0,0 @@
-# Generated from qtx11extras.pro.
-
-cmake_minimum_required(VERSION 3.15.0)
-
-include(.cmake.conf)
-project(QtX11Extras
- VERSION "${QT_REPO_MODULE_VERSION}"
- DESCRIPTION "Qt X11 Extras" # special case
- HOMEPAGE_URL "https://qt.io/"
- LANGUAGES CXX C
-)
-
-# special case begin
-# Make sure we only use latest private CMake API, aka no compatibility wrappers.
-set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
-# special case end
-
-# special case begin
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
-find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Gui Widgets)
-
-if(NOT TARGET Qt::Gui)
- message(NOTICE "Skipping the build as the condition \"TARGET Qt::Gui\" is not met.")
- return()
-endif()
-# special case end
-
-qt_build_repo()
-