summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Faure <david.faure@kdab.com>2020-11-27 16:52:16 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-12-02 20:23:49 +0100
commitba6f4ea0f997a6f1a77295888cfec975a1a02944 (patch)
tree56d4c1165c7a5713fe6f3616ff1fbfa85506417c /CMakeLists.txt
parent0110ca6ffb12d610b88fc117d924cf9b09c2c0fc (diff)
downloadqtx11extras-ba6f4ea0f997a6f1a77295888cfec975a1a02944.tar.gz
qtx11extras: add CMake build system
The coin subdir comes from qtsvg. The dependencies.yaml was inspired by the one in qttools. Change-Id: I3ba6f29641f5e27085920641693ab499184ed8fe Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: David Faure <david.faure@kdab.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..ccb1f5e
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,29 @@
+# Generated from qtx11extras.pro.
+
+cmake_minimum_required(VERSION 3.15.0)
+
+include(.cmake.conf)
+project(QtX11Extras
+ VERSION "${QT_REPO_MODULE_VERSION}"
+ DESCRIPTION "Qt X11 Extras" # special case
+ HOMEPAGE_URL "https://qt.io/"
+ LANGUAGES CXX C
+)
+
+# special case begin
+# Make sure we only use latest private CMake API, aka no compatibility wrappers.
+set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
+# special case end
+
+# special case begin
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
+find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Gui Widgets)
+
+if(NOT TARGET Qt::Gui)
+ message(NOTICE "Skipping the build as the condition \"TARGET Qt::Gui\" is not met.")
+ return()
+endif()
+# special case end
+
+qt_build_repo()
+