summaryrefslogtreecommitdiff
path: root/src/host-c/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/host-c/Makefile.am')
-rw-r--r--src/host-c/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/host-c/Makefile.am b/src/host-c/Makefile.am
index e05b6d98..5dc4c42a 100644
--- a/src/host-c/Makefile.am
+++ b/src/host-c/Makefile.am
@@ -13,7 +13,9 @@ BUILT_SOURCES = rlparse.c rlreduce.cc
EXTRA_DIST = rlparse.lm
-rlparse.pack: rlparse.lm $(COLM) $(COLM_WRAP)
+LM_DEPS = ../ragel.lm ../rlreduce.lm
+
+rlparse.pack: rlparse.lm $(COLM) $(COLM_WRAP) $(LM_DEPS)
$(COLM_WRAP) -c -I .. -b rlparseC -o $@ -p rlparse.c -m rlreduce.cc $<
rlparse.c: rlparse.pack