summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDave Beckett <dave@dajobe.org>2005-05-19 09:41:33 +0000
committerDave Beckett <dave@dajobe.org>2005-05-19 09:41:33 +0000
commitdd1e440075b0855cd54ae64c36cf1dc3e844d44a (patch)
tree87c573fb4171a7d41f580adcae57264ed1e12ce5 /Makefile.am
parent7498c9892177d8a1461943f3a689800b87af1cbc (diff)
downloadraptor-dd1e440075b0855cd54ae64c36cf1dc3e844d44a.tar.gz
Added conditionally included RAPTOR_SERIALIZER_RDFXML_ABBREV
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8fbafffd..403a9a8b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -71,7 +71,7 @@ STANDARD_CFLAGS=@STANDARD_CFLAGS@ $(MEM)
LIBS=@LIBS@ $(MEM_LIBS)
-libraptor_la_SOURCES = raptor_parse.c raptor_serialize.c raptor_serialize_rdfxmla.c\
+libraptor_la_SOURCES = raptor_parse.c raptor_serialize.c \
raptor_rfc2396.c raptor_uri.c raptor_locator.c \
raptor_namespace.c raptor_qname.c \
raptor_feature.c raptor_general.c raptor_utf8.c \
@@ -103,6 +103,11 @@ endif
if RAPTOR_PARSER_GRDDL
libraptor_la_SOURCES += raptor_xslt.c
endif
+# Note other serializers are currently implemented in raptor_serialize.c
+# and cannot be conditionally compiled away as separate files
+if RAPTOR_SERIALIZER_RDFXML_ABBREV
+libraptor_la_SOURCES += raptor_serialize_rdfxmla.c
+endif
if RAPTOR_NFC_CHECK
libraptor_la_SOURCES += raptor_nfc_data.c raptor_nfc.c raptor_nfc.h
endif