summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Beckett <dave@dajobe.org>2014-10-09 22:59:40 +0000
committerDave Beckett <dave@dajobe.org>2014-10-09 22:59:40 +0000
commit4a02384a3f0e90ecd13b155318ed559600221c38 (patch)
treecc90086ad8e73caf78f05f84e267fdd4fe2ecb80 /configure.ac
parent848acd75f6b2d177729770a8d30a4ede1a427b0a (diff)
downloadraptor-4a02384a3f0e90ecd13b155318ed559600221c38.tar.gz
Use __FUNCTION__ (c99) replacing __func__ (c90)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 7e3f9fec..10ff8708 100644
--- a/configure.ac
+++ b/configure.ac
@@ -311,9 +311,9 @@ AC_C_CONST
AC_C_BIGENDIAN
AC_C_INLINE
-AC_MSG_CHECKING(whether __func__ is available)
-AC_COMPILE_IFELSE([AC_LANG_SOURCE([int main() { printf(__func__); }])],
- [AC_DEFINE([HAVE___FUNC__], [1], [Is __func__ available])
+AC_MSG_CHECKING(whether __FUNCTION__ is available)
+AC_COMPILE_IFELSE([AC_LANG_SOURCE([int main() { printf(__FUNCTION__); }])],
+ [AC_DEFINE([HAVE___FUNCTION__], [1], [Is __FUNCTION__ available])
AC_MSG_RESULT(yes)],
[AC_MSG_RESULT(no)])