summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDave Beckett <dave@dajobe.org>2005-08-24 23:08:47 +0000
committerDave Beckett <dave@dajobe.org>2005-08-24 23:08:47 +0000
commit5ccc77b5b1ee9500cfcd8eb10c971e5c57f2b178 (patch)
treed2aa89002a6a9ec9bac2a2adc6882addeb4dfb6a /src/Makefile.am
parent27fb3c9dfb5b5c72115e86053ee9726c3bc7d1cf (diff)
downloadraptor-5ccc77b5b1ee9500cfcd8eb10c971e5c57f2b178.tar.gz
Add more conditional compiles for serializers
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 929aa397..72d98766 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -109,9 +109,14 @@ endif
if RAPTOR_PARSER_GUESS
libraptor_la_SOURCES += raptor_guess.c
endif
-# FIXME: the following 3 serializers cannot be conditionally compiled away
-libraptor_la_SOURCES += raptor_serialize_rdfxml.c \
-raptor_serialize_ntriples.c raptor_serialize_simple.c
+# Always available
+libraptor_la_SOURCES += raptor_serialize_simple.c
+if RAPTOR_SERIALIZER_RDFXML
+libraptor_la_SOURCES += raptor_serialize_rdfxml.c
+endif
+if RAPTOR_SERIALIZER_NTRIPLES
+libraptor_la_SOURCES += raptor_serialize_ntriples.c
+endif
if RAPTOR_SERIALIZER_RDFXML_ABBREV
libraptor_la_SOURCES += raptor_serialize_rdfxmla.c
endif