summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDave Beckett <dave@dajobe.org>2005-01-26 19:51:27 +0000
committerDave Beckett <dave@dajobe.org>2005-01-26 19:51:27 +0000
commitc7bbefaed3cd2f6fca5218bc7884a787ff860c51 (patch)
treecd44e5082cbe12cac43e3826bec8de2918f72f95 /src/Makefile.am
parent00db73f2479fd7d734e4b9c02bc6de1961ef90c0 (diff)
downloadraptor-c7bbefaed3cd2f6fca5218bc7884a787ff860c51.tar.gz
Update Notation3 code with later Turtle improvements.
Built it with maintainer mode only.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ad442fbf..3f919bc9 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -88,6 +88,9 @@ endif
if RAPTOR_PARSER_TURTLE
libraptor_la_SOURCES += turtle_lexer.c turtle_lexer.h turtle_parser.c turtle_parser.h turtle_common.h
endif
+if RAPTOR_PARSER_N3
+libraptor_la_SOURCES += n3_lexer.c n3_lexer.h n3_parser.c n3_parser.h n3_common.h
+endif
if RAPTOR_PARSER_NTRIPLES
libraptor_la_SOURCES += ntriples_parse.c
endif
@@ -177,6 +180,20 @@ turtle_parser.c: $(srcdir)/turtle_parser.y
mv turtle_parser.tab.h turtle_parser.h
rm -f turtle_parser.tab.c
+# Actually it needs n3_parser.h but nevermind
+n3_lexer.c: $(srcdir)/n3_lexer.l n3_parser.c $(srcdir)/fix-flex
+ $(LEX) -o$@ $(srcdir)/n3_lexer.l
+ $(PERL) $(srcdir)/fix-flex $@ > n3_lexer.t
+ mv n3_lexer.t $@
+ $(PERL) $(srcdir)/fix-flex n3_lexer.h > n3_lexer.t
+ mv n3_lexer.t n3_lexer.h
+
+n3_parser.c: $(srcdir)/n3_parser.y
+ $(YACC) -b n3_parser -p n3_parser_ -d -v $(srcdir)/n3_parser.y
+ sed -e '/Suppress GCC warning that yyerrlab1/,/^\#endif/d' -e "s/n3_parser.tab.c/$@/" n3_parser.tab.c > $@
+ mv n3_parser.tab.h n3_parser.h
+ rm -f n3_parser.tab.c
+
endif
# Actually it needs turtle_parser.h but nevermind