summaryrefslogtreecommitdiff
path: root/tests/rdfxml/Makefile.am
diff options
context:
space:
mode:
authorDave Beckett <dave@dajobe.org>2022-06-06 18:19:49 -0700
committerDave Beckett <dave@dajobe.org>2022-06-06 22:07:24 -0700
commit3cca62a33da68143b687c9e486eefc7c7cbb4586 (patch)
tree1d0fc6d5a5bbef9bf224a161671fbd316af702c4 /tests/rdfxml/Makefile.am
parent94a2bb5086db948d83a039fbe6852a6a47f9b588 (diff)
downloadraptor-3cca62a33da68143b687c9e486eefc7c7cbb4586.tar.gz
Fix internal ICU string NFC check to convert to UTF-16 firstt
(raptor_nfc_icu_check, raptor_unicode_check_utf8_nfc_string): Changed signature of these internal functions to not have error_p which wasn't even consistently used. Instead return -1 on failure which is also "falsey" in C. (raptor_nfc_icu_check): Do an UTF-8 (raptor) to UTF-16 conversion before trying to do a NFC normalization check. Update callers of above internal functions to remove error_p argument which was unused in all callers. Update rdfxmla tests to allow tests to throw warnings.
Diffstat (limited to 'tests/rdfxml/Makefile.am')
-rw-r--r--tests/rdfxml/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/rdfxml/Makefile.am b/tests/rdfxml/Makefile.am
index cbb8acc8..a9fe3e7e 100644
--- a/tests/rdfxml/Makefile.am
+++ b/tests/rdfxml/Makefile.am
@@ -451,6 +451,8 @@ check-rdfxmla: build-rdfdiff build-rapper $(check_rdfxmla_deps)
fi; \
if test $$status1 = 0 -a $$status2 = 0; then \
$(RECHO) "ok"; \
+ elif test $$status1 = 2 -a $$status2 = 0; then \
+ $(RECHO) "ok with warnings"; grep Warning $$name.err; \
else \
$(RECHO) "FAILED"; \
echo $(RAPPER) -q -o rdfxml-abbrev $(srcdir)/$$test $$baseuri '>' $$name-rdfxmla.rdf; \