summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 84fc6bbc..7d3f8cde 100644
--- a/configure.ac
+++ b/configure.ac
@@ -336,7 +336,7 @@ AC_C_INLINE
AC_MSG_CHECKING(whether __FUNCTION__ is available)
AC_COMPILE_IFELSE([AC_LANG_SOURCE([#include <stdio.h>
-int main() { printf(__FUNCTION__); }])],
+int main(void) { printf(__FUNCTION__); }])],
[AC_DEFINE([HAVE___FUNCTION__], [1], [Is __FUNCTION__ available])
AC_MSG_RESULT(yes)],
[AC_MSG_RESULT(no)])
@@ -420,7 +420,7 @@ AC_COMPILE_IFELSE([AC_LANG_SOURCE([
#ifdef HAVE_STRING_H
#include <string.h>
#endif
-int main() { return strtok_r(); }
+int main(void) { return strtok_r(); }
])],
[AC_MSG_RESULT(yes)
have_strtok_r=yes