summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 4 insertions, 8 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index da4cce95..906c884a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -219,19 +219,15 @@ turtle_lexer.h: turtle_lexer.c ; @exit 0
turtle_parser.c: $(srcdir)/turtle_parser.y $(top_srcdir)/scripts/fix-bison.pl
$(AM_V_GEN) \
- $(BISON) $(srcdir)/turtle_parser.y; \
- $(PERL) $(top_srcdir)/scripts/fix-bison.pl turtle_parser.tab.c > $@; \
- mv -f turtle_parser.tab.h turtle_parser.h; \
- rm -f turtle_parser.tab.c
+ $(BISON) -o $@ $(srcdir)/turtle_parser.y; \
+ $(PERL) $(top_srcdir)/scripts/fix-bison.pl $@
turtle_parser.h: turtle_parser.c ; @exit 0
parsedate.c: $(srcdir)/parsedate.y $(top_srcdir)/scripts/fix-bison.pl
$(AM_V_GEN) \
- $(BISON) $(srcdir)/parsedate.y; \
- $(PERL) $(top_srcdir)/scripts/fix-bison.pl parsedate.tab.c > $@; \
- mv -f parsedate.tab.h parsedate.h; \
- rm -f parsedate.tab.c
+ $(BISON) -o $@ $(srcdir)/parsedate.y; \
+ $(PERL) $(top_srcdir)/scripts/fix-bison.pl $@
parsedate.h: parsedate.c ; @exit 0