summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNeilBrown <neilb@suse.com>2016-11-16 10:53:07 -0500
committerSteve Dickson <steved@redhat.com>2016-11-19 10:21:57 -0500
commit2e78e6fb51292fea798355e5cb749dbc1de26ca6 (patch)
tree5d8c0733fb4c275250be384a63c2f914e23a2aba /configure.ac
parent0cc39c519278b15ede3a5268415b70a2378a52c0 (diff)
downloadrpcbind-2e78e6fb51292fea798355e5cb749dbc1de26ca6.tar.gz
Move default state-dir to a subdirectory of /var/run
rpcbind can save state in a file to allow restart without forgetting about running services. The default location is currently "/tmp" which is not ideal for system files. It is particularly unpleasant to put simple files there rather than creating a directory to contain them. On a modern Linux system it is preferable to use /run, and there it is even more consistent with practice to use a subdirectory. This directory needs to be create one each boot, and while there are tools (e.g. systemd-tmpfiles) which can do that it is cleaner to keep rpcbind self-contained and have it create the directory. So change the default location to /var/run/rpcbind, and create that directory. If a different user-id is used, we need to create and chown the directory before dropping privileges. We do this with care so avoid chowning the wrong thing by mistake. Signed-off-by: NeilBrown <neilb@suse.com> Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f84921e..acc6914 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,8 +22,8 @@ AC_ARG_ENABLE([warmstarts],
AM_CONDITIONAL(WARMSTART, test x$enable_warmstarts = xyes)
AC_ARG_WITH([statedir],
- AS_HELP_STRING([--with-statedir=ARG], [use ARG as state dir @<:@default=/tmp@:>@])
- ,, [with_statedir=/tmp])
+ AS_HELP_STRING([--with-statedir=ARG], [use ARG as state dir @<:@default=/var/run/rpcbind@:>@])
+ ,, [with_statedir=/var/run/rpcbind])
AC_SUBST([statedir], [$with_statedir])
AC_ARG_WITH([rpcuser],