summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index af4b74b..f84921e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,4 +61,9 @@ AC_SEARCH_LIBS([pthread_create], [pthread])
AC_CHECK_HEADERS([nss.h rpcsvc/mount.h])
-AC_OUTPUT([Makefile])
+# make sbindir available for substitution in config file
+# 2 "evals" needed to expand variable names
+AC_SUBST([_sbindir])
+AC_CONFIG_COMMANDS_PRE([eval eval _sbindir=$sbindir])
+
+AC_OUTPUT([Makefile systemd/rpcbind.service])