summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorjbj <devnull@localhost>1999-06-17 21:35:34 +0000
committerjbj <devnull@localhost>1999-06-17 21:35:34 +0000
commitbafb62fbb0e8d912fe372f776be9280df76e6679 (patch)
tree35a76a85131ff18a4e7c5c5106fae71adff18e37 /Makefile.am
parent8fa7181fa3b0db8e282c03e8df251cb32518bfa3 (diff)
downloadrpm-bafb62fbb0e8d912fe372f776be9280df76e6679.tar.gz
MiNT port (Guido Flohr <gufl0000@stud.uni-sb.de>).
CVS patchset: 3096 CVS date: 1999/06/17 21:35:34
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 481066b80..9b121d5ad 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -58,7 +58,8 @@ rpm2cpio_SOURCES = rpm2cpio.c
rpm2cpio_LDADD = $(mylibs)
rpmconvert_SOURCES = convertdb.c oldrpmdb.c
-rpmconvert_LDADD = $(mylibs) -lgdbm
+## Libmisc.a is required for rpmconvert.
+rpmconvert_LDADD = $(mylibs) @LIBMISC@ -lgdbm
install-data-local:
@$(mkinstalldirs) $(DESTDIR)$(varprefix)/lib/rpm
@@ -73,7 +74,13 @@ install-data-local:
sparc*) $(mkinstalldirs) $(DESTDIR)/$(prefix)/src/redhat/RPMS/sparc ;;\
powerpc*) $(mkinstalldirs) $(DESTDIR)/$(prefix)/src/redhat/RPMS/ppc ;;\
esac
- @$(mkinstalldirs) $(DESTDIR)/$(prefix)/src/redhat/RPMS/@build_cpu@
+ @case "@build_os@" in \
+ mint) $(mkinstalldirs) $(DESTDIR)/$(prefix)/src/redhat/RPMS/m68kmint ;; \
+ esac
+ @case "@build_os@" in \
+ mint) $(mkinstalldirs) $(DESTDIR)/$(prefix)/src/redhat/RPMS/m68kmint ;;\
+ *) @$(mkinstalldirs) $(DESTDIR)/$(prefix)/src/redhat/RPMS/@build_cpu@ ;;\
+ esac
@$(mkinstalldirs) $(DESTDIR)/$(prefix)/src/redhat/RPMS/noarch
@$(mkinstalldirs) $(DESTDIR)/$(prefix)/src/redhat/SOURCES
@$(mkinstalldirs) $(DESTDIR)/$(prefix)/src/redhat/SPECS