summaryrefslogtreecommitdiff
path: root/tests/data/SPECS
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2018-02-16 14:29:28 +0200
committerPanu Matilainen <pmatilai@redhat.com>2018-02-16 14:29:28 +0200
commit7400a36b982fd315eb30d893321af0283f57205d (patch)
tree58c0be63d7b2aa6f71becb1ee3acbae7e3590fac /tests/data/SPECS
parentc3991587c92c365551436f03de09cfe5a31f3e9f (diff)
downloadrpm-7400a36b982fd315eb30d893321af0283f57205d.tar.gz
Eliminate file trigger second argument (aka $2)
File triggers have gotten both $1 and $2 as zero always, which doesn't make a whole lot of sense. For $1 we know what to do (it should be the same as with all other scriptlet types) but $2 is not so obvious. For regular triggers it's the number of remaining instances of the target package, but with file triggers there are any number of target packages and it's not clear what the most useful thing would be. Better not pass it at all to make it free for future use once we figure what to do with it.
Diffstat (limited to 'tests/data/SPECS')
-rw-r--r--tests/data/SPECS/filetriggers.spec2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/data/SPECS/filetriggers.spec b/tests/data/SPECS/filetriggers.spec
index 3e2ee0034..35d0fb9ee 100644
--- a/tests/data/SPECS/filetriggers.spec
+++ b/tests/data/SPECS/filetriggers.spec
@@ -43,7 +43,7 @@ cat
echo
%filetriggerin -p <lua> -- /usr/bin
-print("filetriggerin(/usr/bin*)<lua>: "..arg[2].." "..arg[3])
+print("filetriggerin(/usr/bin*)<lua>: "..arg[2])
a = rpm.next_file()
while a do
print(a)