summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2a71946cf..e965688a3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -194,11 +194,8 @@ endif()
if (WITH_IMAEVM)
list(APPEND REQFUNCS lsetxattr)
- find_path(IMA_INCLUDE_DIR NAMES imaevm.h)
- find_library(IMA_LIBRARY NAMES imaevm)
- if (NOT (IMA_INCLUDE_DIR AND IMA_LIBRARY))
- message(FATAL_ERROR "imaevm enabled but library not present")
- endif()
+ find_path(IMA_INCLUDE_DIR NAMES imaevm.h REQUIRED)
+ find_library(IMA_LIBRARY NAMES imaevm REQUIRED)
endif()
find_program(__FIND_DEBUGINFO find-debuginfo)