summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWayne Davison <wayne@opencoder.net>2020-06-12 08:02:51 -0700
committerWayne Davison <wayne@opencoder.net>2020-06-12 08:29:36 -0700
commit1efeb59166b7638779c4dc4e6ffcd599fa0ca24b (patch)
treefd84afc8226670993f2149c3fb9942eebafe6b02 /configure.ac
parentd4fc18f3755987ccea6e7f43609f862aa0254c5a (diff)
downloadrsync-1efeb59166b7638779c4dc4e6ffcd599fa0ca24b.tar.gz
Enable SIMD by default (if g++ is around).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 372399c2..17b0a637 100644
--- a/configure.ac
+++ b/configure.ac
@@ -163,9 +163,9 @@ SIMD=
AC_MSG_CHECKING([whether to enable SIMD optimizations])
AC_ARG_ENABLE(simd,
- AS_HELP_STRING([--enable-simd],[enable SIMD optimizations]))
+ AS_HELP_STRING([--disable-simd],[disable SIMD optimizations (requires g++)]))
-if test x"$enable_simd" = x"yes"; then
+if test x"$enable_simd" != x"no"; then
# For x86-64 SIMD, g++ is also required
if test x"$build_cpu" = x"x86_64" && test x"$CXX" = x"g++"; then
SIMD="$SIMD x86_64"
@@ -236,7 +236,7 @@ ipv6lib=none
ipv6trylibc=yes
AC_ARG_ENABLE(ipv6,
- AS_HELP_STRING([--disable-ipv6],[do not even try to use IPv6]))
+ AS_HELP_STRING([--disable-ipv6],[turn off IPv6 support]))
if test x"$enable_ipv6" != x"no"; then
AC_MSG_CHECKING([ipv6 stack type])
for i in inria kame linux-glibc linux-inet6 solaris toshiba v6d zeta cygwin; do