summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWayne Davison <wayne@opencoder.net>2022-06-19 10:02:51 -0700
committerWayne Davison <wayne@opencoder.net>2022-06-19 10:11:28 -0700
commit3592ac3c025da23b2dd291561ec6113940b9c11b (patch)
treed46fa2282ac1acceb3d5db367a99e661b5f68782 /configure.ac
parentc897b16f3231b2c22110b3792ec63c4b269d57d6 (diff)
downloadrsync-3592ac3c025da23b2dd291561ec6113940b9c11b.tar.gz
Include bsd/strings.h if it exists
Some systems apparently put strlcpy() into a separate bsd/strings.h file without putting the function into a separate library. Thus, configure finds that the function exists for linking but the build does not have the declaration (which rsync only supplies if it is also supplying its own version of the function).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 37dbb18a..37241637 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,7 +13,8 @@ AC_CHECK_HEADERS(sys/fcntl.h sys/select.h fcntl.h sys/time.h sys/unistd.h \
netdb.h malloc.h float.h limits.h iconv.h libcharset.h langinfo.h mcheck.h \
sys/acl.h acl/libacl.h attr/xattr.h sys/xattr.h sys/extattr.h dl.h \
popt.h popt/popt.h linux/falloc.h netinet/in_systm.h netgroup.h \
- zlib.h xxhash.h openssl/md4.h openssl/md5.h zstd.h lz4.h sys/file.h)
+ zlib.h xxhash.h openssl/md4.h openssl/md5.h zstd.h lz4.h sys/file.h \
+ bsd/string.h)
AC_CHECK_HEADERS([netinet/ip.h], [], [], [[#include <netinet/in.h>]])
AC_HEADER_MAJOR_FIXED