summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWayne Davison <wayne@opencoder.net>2020-06-16 11:35:54 -0700
committerWayne Davison <wayne@opencoder.net>2020-06-16 11:35:54 -0700
commit38ecf188d91096ca383d115243f91fae70173ce5 (patch)
treeec4121972c1eaa593b4aad8484d595346b9ea721 /configure.ac
parent29be5eddded2c882ba73b44a9ec504702321fa36 (diff)
downloadrsync-38ecf188d91096ca383d115243f91fae70173ce5.tar.gz
Only complain about lack of g++ on linux for now.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f70bbaea..c9e4256d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -197,10 +197,17 @@ if test x"$enable_simd" != x"no"; then
# For x86-64 SIMD, g++ is also required
if test x"$build_cpu" = x"x86_64"; then
if test x"$CXX" = x"g++"; then
+ # AC_MSG_RESULT() called below
SIMD="$SIMD x86_64"
else
AC_MSG_RESULT(no)
- AC_MSG_ERROR(Failed to find g++ for SIMD speedups. Use --disable-simd to continue without it.)
+ case "$host_os" in
+ *linux*)
+ AC_MSG_ERROR(Failed to find g++ for SIMD speedups. Use --disable-simd to continue without it.)
+ ;;
+ *)
+ ;;
+ esac
fi
fi
fi
@@ -208,7 +215,7 @@ fi
if test x"$SIMD" != x""; then
SIMD=`echo "$SIMD" | sed -e 's/^ *//'`
AC_MSG_RESULT([yes ($SIMD)])
- AC_DEFINE(HAVE_SIMD, 1, [Define to 1 to enable SIMD optimizations])
+ AC_DEFINE(HAVE_SIMD, 1, [Define to 1 to enable SIMD optimizations])
SIMD=`echo "$SIMD" | sed -e 's/[[^ ]]\+/$(SIMD_&)/g'`
# We only use g++ for its target attribute dispatching, disable unneeded bulky features
CXXFLAGS="$CXXFLAGS -fno-exceptions -fno-rtti"