summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWayne Davison <wayne@opencoder.net>2020-06-28 13:46:48 -0700
committerWayne Davison <wayne@opencoder.net>2020-06-28 15:02:19 -0700
commit3b4f5fb891e57ecda3fe09c3b93fc458c8cc81a7 (patch)
tree6c19ee1a231e77a7c74d9fbedf40c72cb50d99e5 /configure.ac
parent76064b1bf29b132bbc684a27520d9cf465239f0f (diff)
downloadrsync-3b4f5fb891e57ecda3fe09c3b93fc458c8cc81a7.tar.gz
Move the version string out of configure.ac.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 9275ce75..3676a716 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,16 +1,15 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT([rsync],[3.2.2pre1],[https://rsync.samba.org/bugtracking.html])
+AC_INIT([rsync],[],[https://rsync.samba.org/bugtracking.html])
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_SRCDIR([byteorder.h])
AC_CONFIG_HEADER(config.h)
AC_PREREQ([2.69])
-AC_SUBST(RSYNC_VERSION, $PACKAGE_VERSION)
-AC_MSG_NOTICE([Configuring rsync $PACKAGE_VERSION])
+PACKAGE_VERSION=`sed 's/.*"\(.*\)".*/\1/' <$srcdir/version.h`
-AC_DEFINE_UNQUOTED(RSYNC_VERSION, ["$PACKAGE_VERSION"], [rsync release version])
+AC_MSG_NOTICE([Configuring rsync $PACKAGE_VERSION])
LDFLAGS=${LDFLAGS-""}
@@ -1338,5 +1337,5 @@ AC_CONFIG_FILES([Makefile lib/dummy zlib/dummy popt/dummy shconfig])
AC_OUTPUT
AC_MSG_RESULT()
-AC_MSG_RESULT([ rsync ${RSYNC_VERSION} configuration successful])
+AC_MSG_RESULT([ rsync $PACKAGE_VERSION configuration successful])
AC_MSG_RESULT()