summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWayne Davison <wayne@opencoder.net>2022-08-01 09:00:34 -0700
committerWayne Davison <wayne@opencoder.net>2022-08-01 09:00:34 -0700
commit51fd4993baa21f4df4b3b188899bd71fc062a5a7 (patch)
tree32e980fc26b4084414c6545a54f9b344da95d086 /configure.ac
parente37bfdb445fc3ec500699fcee7c4ef8608938171 (diff)
downloadrsync-51fd4993baa21f4df4b3b188899bd71fc062a5a7.tar.gz
Avoid the getgroups program when cross-compiliing.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 37241637..d185b2d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -625,7 +625,11 @@ fi
AC_TYPE_UID_T
AC_CHECK_TYPES([mode_t,off_t,size_t,pid_t,id_t])
-AC_TYPE_GETGROUPS
+if test "$cross_compiling" = no; then
+ AC_TYPE_GETGROUPS
+else
+ AC_DEFINE([GETGROUPS_T],[gid_t],[Define to the type of elements in the array set by `getgroups'. Usually this is either `int' or `gid_t'.])
+fi
AC_CHECK_MEMBERS([struct stat.st_rdev,
struct stat.st_mtimensec,
struct stat.st_mtimespec.tv_nsec,