summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWayne Davison <wayne@opencoder.net>2020-06-16 22:59:54 -0700
committerWayne Davison <wayne@opencoder.net>2020-06-16 23:00:01 -0700
commit643b9d0183d240735de14a06d682018977634b0e (patch)
tree727f319198d8f2c1b0b8e47d4a6d5c1587aca19d /configure.ac
parent2c681b874e181bac740d208daf158fd76d9023b6 (diff)
downloadrsync-643b9d0183d240735de14a06d682018977634b0e.tar.gz
Change SIMD back to disabled unless requested.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 4 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index d8f44d6b..f1f075df 100644
--- a/configure.ac
+++ b/configure.ac
@@ -197,9 +197,9 @@ SIMD=
AC_MSG_CHECKING([whether to enable SIMD optimizations])
AC_ARG_ENABLE(simd,
- AS_HELP_STRING([--disable-simd],[disable SIMD optimizations (requires g++)]))
+ AS_HELP_STRING([--enable-simd],[enable SIMD optimizations (requires g++)]))
-if test x"$enable_simd" != x"no"; then
+if test x"$enable_simd" = x"yes"; then
# For x86-64 SIMD, g++ is also required
if test x"$build_cpu" = x"x86_64"; then
if test x"$CXX" = x"g++"; then
@@ -207,13 +207,8 @@ if test x"$enable_simd" != x"no"; then
SIMD="$SIMD x86_64"
else
AC_MSG_RESULT(no)
- case "$host_os" in
- *linux*)
- AC_MSG_ERROR(Failed to find g++ for SIMD speedups. Use --disable-simd to continue without it.)
- ;;
- *)
- ;;
- esac
+ AC_MSG_ERROR(Failed to find g++ for SIMD speedups.
+Omit --enable-simd to continue without it.)
fi
fi
fi