summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorbenrubson <6764151+benrubson@users.noreply.github.com>2020-06-16 23:42:12 +0200
committerWayne Davison <wayne@opencoder.net>2020-06-16 15:05:36 -0700
commit6a22f4fee1b54c83d725830d3b8fb1d8cf94b7f2 (patch)
tree096bf08d39a0862a6d82094a7089e7914eb80d06 /configure.ac
parentd90990d6acbfb592d3c989e423db4768b8c46d74 (diff)
downloadrsync-6a22f4fee1b54c83d725830d3b8fb1d8cf94b7f2.tar.gz
enh(configure) Promote OpenSSL crypto lib support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 12 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 03fad912..efce10d5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -423,9 +423,18 @@ AC_ARG_ENABLE([openssl],
AS_HELP_STRING([--disable-openssl],[disable openssl crypto library]))
AH_TEMPLATE([USE_OPENSSL],
[Undefine if you do not want to use openssl crypto library. By default this is defined.])
-if test x"$enable_openssl" != x"no" && test x"$ac_cv_header_openssl_md4_h" = x"yes" && test x"$ac_cv_header_openssl_md5_h" = x"yes"; then
- AC_MSG_RESULT(yes)
- AC_SEARCH_LIBS(MD5_Init, crypto, [AC_DEFINE(USE_OPENSSL)])
+if test x"$enable_openssl" != x"no"; then
+ if test x"$ac_cv_header_openssl_md4_h" = x"yes" && test x"$ac_cv_header_openssl_md5_h" = x"yes"; then
+ AC_MSG_RESULT(yes)
+ AC_SEARCH_LIBS(MD5_Init, crypto,
+ [AC_DEFINE(USE_OPENSSL)],
+ [AC_MSG_ERROR(Failed to find MD5_Init function in openssl crypto lib.
+Use --disable-openssl to continue without openssl crypto lib support.)])
+ else
+ AC_MSG_RESULT(no)
+ AC_MSG_ERROR(Failed to find openssl/md4.h and openssl/md5.h for openssl crypto lib support.
+Use --disable-openssl to continue without it.)
+ fi
else
AC_MSG_RESULT(no)
fi