summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWayne Davison <wayne@opencoder.net>2021-12-26 12:29:00 -0800
committerWayne Davison <wayne@opencoder.net>2021-12-26 12:29:00 -0800
commit72adf49ba8cb81426e2b9799fbd43c6284b013a9 (patch)
tree23dd23c64c4604fac8062fac83c3c64d36eadd0e /configure.ac
parent73ceea6ad2af00f251a5e79a0a258f9fee97d531 (diff)
downloadrsync-72adf49ba8cb81426e2b9799fbd43c6284b013a9.tar.gz
rrsync improvements
- Convert rrsync to python. - Enhance security of arg & option checking. - Reject `-L` (`--copy-links`) by default. - Add `-munge` and `-no-del` options. - Tweak the logfile line format. - Created an rrsync man page. - Use `configure --with-rrsync` if you want `make install` to install rrsync and its man page. - Give lsh more rrsync testing support.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9e7338cf..84111de8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -136,6 +136,13 @@ if test x"$GCC" = x"yes"; then
CFLAGS="$CFLAGS -Wall -W"
fi
+AC_ARG_WITH(rrsync,
+ AS_HELP_STRING([--with-rrsync],[also install the rrsync script and its man page]))
+if test x"$with_rrsync" != x"yes"; then
+ with_rrsync=no
+fi
+AC_SUBST(with_rrsync)
+
AC_ARG_WITH(included-popt,
AS_HELP_STRING([--with-included-popt],[use bundled popt library, not from system]))