summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWayne Davison <wayne@opencoder.net>2020-06-18 16:27:05 -0700
committerWayne Davison <wayne@opencoder.net>2020-06-18 16:28:28 -0700
commit7fd24bef0fb5d3f7e07af433cfbdea0f00becdbc (patch)
treec15cb4bd607aa75005eb109f276a149bc0af34e9 /configure.ac
parent1a9a184145b93614389f227657e63c9e899e4dde (diff)
downloadrsync-7fd24bef0fb5d3f7e07af433cfbdea0f00becdbc.tar.gz
Make SIMD enabled by default again (for x86_64)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index a01dd701..3330eb90 100644
--- a/configure.ac
+++ b/configure.ac
@@ -198,9 +198,9 @@ SIMD=
AC_MSG_CHECKING([whether to enable SIMD optimizations])
AC_ARG_ENABLE(simd,
- AS_HELP_STRING([--enable-simd],[enable SIMD optimizations (requires c++)]))
+ AS_HELP_STRING([--disable-simd],[disable SIMD optimizations (requires c++)]))
-if test x"$enable_simd" = x"yes"; then
+if test x"$enable_simd" != x"no"; then
# For x86-64 SIMD, g++ >=5 or clang++ >=7 is required
if test x"$build_cpu" = x"x86_64"; then
if test x"$CXX" != x""; then
@@ -228,13 +228,13 @@ if test x"$enable_simd" = x"yes"; then
else
AC_MSG_RESULT(error)
AC_MSG_ERROR([Failed to find g++ >=5 or clang++ >=7 for SIMD optimizations.
-Omit --enable-simd to continue without it. ($CXX, $CXX_VERSION)])
+Specify --disable-simd to continue without it. ($CXX, $CXX_VERSION)])
fi
fi
- else
+ elif test x"$enable_simd" = x"yes"; then
AC_MSG_RESULT(unavailable)
AC_MSG_ERROR(The SIMD optimizations are currently x86_64 only.
-Omit --enable-simd to continue.)
+Omit --enable-simd to continue without it.)
fi
fi